PHPFileUpload Not working properly

Sep 11, 2009 at 8:15 PM

Hi, 

I've loaded the PhpFileUpload code on my web server and changed the filePath in the upload.php file to point to the web server. When I run the test.php file, the initial selection box appears, I depress 'select files', the file selection box opens, I select one or more files and depress 'open' and the files appear as 'pending'. Next I depress 'upload' and the status changes to 'uploading' but just remains there with no further action. 

I'm using an Apache web server from site5.com. I added a mime type xap as 'application/x-silverlight-2' on the server. In the upload.php my file path is '$filePath = $filename;'. I see no errors in the error log. From what I can determine, the only required files are test.php, upload.php and FileUpload.xap. 

Has anyone experience this problem and have a solution? 

 

Thanks . . .

Sep 11, 2009 at 8:58 PM

Does the application have write permissions where you are saving the uploaded file?

-Darick

Sep 11, 2009 at 9:16 PM

Yes. Permissions are set to 755 and I used a php file to verify that I could write to the directory. I also tried using a different xap file (mpost.SilverlightMultiFileUpload.xap) and while it showed upload progress it ended in an upload failed message.

Sep 11, 2009 at 9:34 PM
Edited Sep 11, 2009 at 9:54 PM

UPDATE: When using the other xap file (mpost.SilverlightMultiFileUpload.xap) and their code, if I change this line it works:

<param name="initParams" value="HttpUploader=true,UploadHandlerName=PHPUpload.php,DefaultColor=Green" />
Now I just need to experiment with that parameter field on the original xap file which I like more.
Thanks . . .
Sep 18, 2009 at 12:33 AM
Edited Sep 18, 2009 at 4:31 PM

[deleted post] wrong forum . . .